Turkcell | Geleceği Yazanlar

Soru & Cevap

Firebase ile kayıt olma özelliği eklemeye çalışırken hata

31.08.2019 - 01:41

Could not find firebase-auth-15.0.0.jar (com.google.firebase:firebase-auth:16.0.1).
Searched in the following locations:
    https://dl.google.com/dl/android/maven2/com/google/firebase/firebase-auth/16.0.1/firebase-auth-16.0.1-15.0.0.jar

Hata olarak bunu veriyor

 

build.gradle module:app şu şekilde;

apply plugin: 'com.android.application'
apply plugin: 'com.google.gms.google-services'

android {
    compileSdkVersion 28
    defaultConfig {
        applicationId "com.busesenturk.dahayeil"
        minSdkVersion 15
        targetSdkVersion 28
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:28.0.0'
    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    implementation 'com.android.support:support-v4:28.0.0'
    implementation 'com.android.support:design:28.0.0'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'

    //Add Library
    implementation 'de.hdodenhof:circleimageview:2.1.0'
    implementation 'com.github.siyamed:android-shape-imageview:0.9.+@aar'

    implementation 'com.google.firebase:firebase-auth:16.0.1:15.0.0'
}

 

 

Lütfen yardımcı olabilir misiniz?

5 Cevap

Buse Şentürk
09.09.2019 - 01:18

Hepinize çok teşekkür ederim o hatayı düzelttim fakat

Manifest merger failed : Attribute application@appComponentFactory value=(android.support.v4.app.CoreComponentFactory) from [com.android.support:support-compat:28.0.0] AndroidManifest.xml:22:18-91 is also present at [androidx.core:core:1.0.0] AndroidManifest.xml:22:18-86 value=(androidx.core.app.CoreComponentFactory). Suggestion: add 'tools:replace="android:appComponentFactory"' to element at AndroidManifest.xml:5:5-105:19 to override.

hatasını verdi tools:replace="android:appComponentFactory" bu satırı eklediğimde ise

Manifest merger failed with multiple errors, see logs hatası ile karşılaştım hata olarakta bunları verdi; Merging Errors: Error: tools:replace specified at line:6 for attribute android:appComponentFactory, but no new value specified app main manifest (this file), line 5 Error: Validation failed, exiting app main manifest (this file)

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    xmlns:tools="http://schemas.android.com/tools"
    package="com.busesenturk.dahayeil">

    <application
        android:allowBackup="true"
        android:icon="@mipmap/ic_launcher"
        android:label="@string/app_name"
        android:roundIcon="@mipmap/ic_launcher_round"
        android:supportsRtl="true"
        tools:replace="android:appComponentFactory"
        android:theme="@style/AppTheme"
        tools:ignore="GoogleAppIndexingWarning">
        <activity android:name=".MainActivity">
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />

                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
        </activity>

 kodum şu şekilde hatayı nasıl düzeltebileceğim ile ilgili bir fikriniz var mı

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Recep Özen
09.09.2019 - 23:37
Şuan aldığınız hata firebase ile kısmen alakası yok bu hata sdk uyuşmazlığından kaynaklanıyor. minSdkVersion 16 yapın ve tekrar deneyin eğer olmaz ise uygulamanı andoroidx e geçirmeyi deneye bilirsin. Uygulama app klasörüne sağ tıkla Refactor/Migrate to Androidx i tıklayarak uygulamanı AndroidX e geçire bilirsin apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 28 defaultConfig { applicationId "com.busesenturk.dahayeil" minSdkVersion 16 targetSdkVersion 28 versionCode 1 versionName "1.0" testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro' } } } dependencies { implementation fileTree(dir: 'libs', include: ['*.jar']) implementation 'androidx.appcompat:appcompat:1.0.0' implementation 'androidx.legacy:legacy-support-v4:1.0.0' implementation 'com.google.android.material:material:1.0.0' implementation 'androidx.constraintlayout:constraintlayout:1.1.3' implementation 'com.google.firebase:firebase-core:16.0.9' implementation 'com.google.firebase:firebase-database:17.0.0' implementation 'com.google.firebase:firebase-auth:17.0.0' implementation 'com.google.firebase:firebase-storage:17.0.0' testİmplementation 'junit:junit:4.12' androidTestİmplementation 'androidx.test:runner:1.1.0' androidTestİmplementation 'androidx.test.espresso:espresso-core:3.1.0' implementation 'com.android.support:support-compat:28.0.0' }
ibrahim mert
03.09.2019 - 11:39

emre aydemirin yorumunuda dikkate alın ilk önce 16 olarak deniyebilirsiniz.

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Emre Aydemir
02.09.2019 - 10:21

minSdkVersion 16 yaparsan düzelecektir. Android Studio içerisindeki eklenti üzerinden firebase entegrasyonunu yaparsan sorunsuz ilerleyebilirsin.

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Buse Şentürk
09.09.2019 - 01:16
teşekkür ederim o hatayı düzelttim fakat Manifest merger failed : Attribute application@appComponentFactory value=(android.support.v4.app.CoreComponentFactory) from [com.android.support:support-compat:28.0.0] AndroidManifest.xml:22:18-91 is also present at [androidx.core:core:1.0.0] AndroidManifest.xml:22:18-86 value=(androidx.core.app.CoreComponentFactory). Suggestion: add 'tools:replace="android:appComponentFactory"' to <application> element at AndroidManifest.xml:5:5-105:19 to override. hatasını verdi tools:replace="android:appComponentFactory" bu satırı eklediğimde ise Manifest merger failed with multiple errors, see logs hatası ile karşılaştım hata olarakta bunları verdi; Merging Errors: Error: tools:replace specified at line:6 for attribute android:appComponentFactory, but no new value specified app main manifest (this file), line 5 Error: Validation failed, exiting app main manifest (this file) <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" package="com.busesenturk.dahayeil"> <application android:allowBackup="true" android:icon="@mipmap/ic_launcher" android:label="@string/app_name" android:roundIcon="@mipmap/ic_launcher_round" android:supportsRtl="true" tools:replace="android:appComponentFactory" android:theme="@style/AppTheme" tools:ignore="GoogleAppIndexingWarning"> <activity android:name=".MainActivity"> <intent-filter> <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> </intent-filter> </activity> kodum şu şekilde hatayı nasıl düzeltebileceğim ile ilgili bir fikriniz var mı
Mert Tülümen
31.08.2019 - 18:12

En güncel Firabase pluginini kullanmayı dene o olmazsa bir versiyon altını dene

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

ibrahim mert
31.08.2019 - 12:33

buraya bakabilirsin https://firebase.google.com/docs/android/setup

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Buse Şentürk
01.09.2019 - 13:31
Yanıtınız için teşekkür ederim fakat bu siteden bakıp yaptığım halde Failed to resolve: firebase-auth-15.0.0 şeklinde bir hata alıyorum implementation 'com.google.firebase:firebase-auth:16.0.1:15.0.0' buradaki 15.0.0 ı silince Manifest merger failed : uses-sdk:minSdkVersion 15 cannot be smaller than version 16 declared in library diyor ne yapmam lazım yardımcı olabilir misiniz?
ibrahim mert
03.09.2019 - 18:34
versiyon sorunu yaşıyorsunuzda şu videodakini deneyin. https://www.youtube.com/watch?v=fmidHtiFfA8

Sitedeki sorulara cevap verebilmek için giriş yapın ya da üye olun.