Soru & Cevap

Android Action Bar Sürümü

28.06.2014 - 03:47

Arkadaşlar merhaba , yaptığım android uygulamada action bar ekliyorum.Fakat 3.0  altında çalıştırmadığı için alt sürümlerde çalışmıyor.Bunun bir çözümü var mı alt sürümlerde yaptıgım action bar'ı nasıl çalıştırabilirim ? 

0 Görüntülenme

2 Cevap

Sitedeki sorulara cevap verebilmek için giriş yapın ya da üye olun.

picture-1372-1408467635.jpg
ahmtbrk
28.06.2014 - 05:18

Bu soru bu ara portalda çok sorulmaya başladı 2 ayrı alternatif çözümü var.

Birincisi http://actionbarsherlock.com/ (ActionBarSherlock) kütüphanesini kullanmak.

http://stackoverflow.com/questions/10867617/how-do-i-use-the-actionbar-on-older-versions-of-android/10867672#10867672

adım adım burada kütüphaneyi indirdikten sonra ne yapacağınız yazıyor.

Activity'niz SherlockActivity,getActionBar() ise getSupportActionBar() halini alacak.

İkincisi ise google api level 18 güncellemesinde ActionBarı support kütüphanesine ekledi.

Kullanabilmek için android.support.v7.appcompat 'i projenize dahil edin ve activity'i ActionBarActivityden extend edin.

Bu sayede ActionBar'ı API Level 7'e kadar kullanabilirsiniz

ecemokan
28.06.2014 - 07:31
Cevabınız için teşekkür ederim