Turkcell | Geleceği Yazanlar

Soru & Cevap

Hata aliyorum(Jar mismatch! Fix your dependencies)

29.05.2014 - 15:26

Merhabalar,

Jar mismatch! Fix your dependenciesFound 4 versions of android-support-v4.jar in the dependency list,but not all the versions are identical (check is based on SHA-1 only at this time).All versions of the libraries must be the same at this time. 

bu hatayi aliyorum ..

Birden fazla library kullaniyorum.Support jar i cakisiyor sanirim . Diger projelerdeki supportlarimi silmem lazm? nasil olmasi gerekiyor?

4733 Görüntülenme

2 Cevap

Yasin Yildirim
09.06.2014 - 19:49

Sorun farkli librarylerdeki ve sizin uygulamanizin libs folder'indaki android-support-v4.jar'in farkli versiyonlar olmasi. Bunu cozebilmek icin

  • Android SDK'nizi en guncel versiyona update edin.
  • Sonra Android SDK'nin extras/android/support/v4/android-support-v4.jar'i kopyalayin
  • Son olarak kendi uygulamanizin ve kullandiginiz butun library'lerin libs folderlarindaki android-support-v4.jar'i SDK'dan kopyaladiginiz jar olarak degistirin.

Sonuc olarak uygulamaniz ve tum libraryler birbirinin aynisi ve ayni zamanda en guncel android-support-v4.jar'a sahip olmus olur.

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Baki Mustafa
29.05.2014 - 23:29

Merhaba Sultan,

Kütüphanedeki android-support-v4'u dahil etmeyin. Yerine harici kütüphane ekleyin.

Build path menu > Add external jar- Uptade yaparak kütühnanenizi güncelleyebilirsiniz..

Unutmayınız Her zaman Project-Clean adımını projenizde sık sık gerçekleştiriniz. İyi çalışmalar..

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Sitedeki sorulara cevap verebilmek için giriş yapın ya da üye olun.