Soru & Cevap

JDK ve Eclipse sorunu ...

29.11.2015 - 09:09

Arkadaşlar jdk yı ve eclipse yi indirdim ama eclipse yi çalıştıramadım bir türlü. Hata mesajı verip duruyor. Yardım edebilecek var mı?

1,126 Görüntülenme

6 Cevap

Sitedeki sorulara cevap verebilmek için giriş yapın ya da üye olun.

Profile picture for user basarakyildiz
basarakyildiz
05.12.2020 - 01:30

Muhtemelen sorunun kaynağı Eclipse'nin JDK'yı bulamamasıdır. Bunun çözümü ise indirmiş olduğun 11.0.0 ve üstü Java'nın Eclipse'ye tanıtılmasıdır.

Bunun için Eclipse'ye girip eclipse.ini 'yi aç.

"Launcher..... ile "-Vmargs" yazan yer arasına 3 satır boşluk bırak. 

Ortadaki boşluğa "-vm" yazıp bir satır daha bırakıp alttaki satıra indirmiş olduğun java 11.0.0 sürümü ve üzeri Java'nın bin klasörüne giden dizini kopyalayıp yapıştıracaksın. Ardından \javaw.exe yapıp kaydedeceksin.

Yukarıdaki anlattığım dizin kopyalamaya örnek olarak "C:\Program Files\Java\jdk-15.0.1\bin" şeklini veriyorum.Sonuna java.exe eklemeyi ise "C:\Program Files\Java\jdk-15.0.1\bin\javaw.exe" şeklinde gösteriyorum.

Muhtemelen sorunun çözülecektir. Bu konuyla ilgili detaylı anlatım youtube içeriğinde mevcuttur.

https://www.youtube.com/watch?v=jTNU_N3PQQYsaA_xalBIw

Profile picture for user fhrypl
fhrypl
05.02.2019 - 08:32

bende jre bulunamadı hatası veriyor yüklerken hiç kuramadım neden kaynaklanıyor olablir??

Ali Keskin
05.02.2019 - 08:51
PATH ı hatalıdır.
Profile picture for user yalponzo
yalponzo
06.12.2015 - 07:12

Hata eclipse.ini dosyasının içerisindeki yapılandırma ayarları ile alakalı eclipse klasöründe eclipse.ini (eclipse simgesinin altındaki dosya) uzantılı dosyayı wordpad de açıp aşağıdaki kodları yazarsan sorun düzelecektir. (En güncel java)

İyi Çalışmalar

-startup
plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.300.v20150602-1417
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
C:/Program Files/Java/jdk1.7.0_80/jre/bin/javaw.exe
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.7
-Xms256m
-Xmx1024m

 

Profile picture for user aisingor
aisingor
02.12.2015 - 04:13

Hata mesajı nedir?

fahriye palabıyık
05.02.2019 - 08:34
bende jre bulunamadı hatası veriyor yüklerken hiç kuramadım neden kaynaklanıyor olablir??
Profile picture for user ZiyaKeskin
ZiyaKeskin
30.11.2015 - 10:18

2 sinide kaldır önce jdk'yı kur sonra eclipse'i kur.

picture-28812-1452251417.jpg
umutonur
29.11.2015 - 09:42

Version uyuşmazlığı olabilir..

Işletim Sisteminin, Kurduğun Java'nın ve Eclipse'in versiyonları aynı olmalı.

Mesela Işletim Sistemin 32-Bit ise;

- 32-Bit Java

- 32-Bit Eclipse kurmalısın..

lryuga
29.11.2015 - 09:58
İkisi de uyumlu, 64 bit için olanları yükledim