Soru & Cevap

Veri Bilimi; OSError: ...

08.05.2020 - 01:29

Merhaba,

!pip install ycimpute

kodunda

ERROR: Could not find a version that satisfies the requirement torch>=1.1.0 (from ycimpute) (from versions: 0.1.2, 0.1.2.post1, 0.1.2.post2)
ERROR: No matching distribution found for torch>=1.1.0 (from ycimpute)

hatasını alırken terminal üzerinden

conda install pytorch -c pytorch

ile bu problemi çözdüm. Şu an

from ycimpute.imputer import knnimput

kodundan 

OSError: [WinError 126] Belirtilen modül bulunamadı

hatasını almaktayım. Fikir ve çözümleriniz nelerdir? Teşekkürler.

221 Görüntülenme

2 Cevap

Sitedeki sorulara cevap verebilmek için giriş yapın ya da üye olun.

Profile picture for user birsen45
birsen45
05.08.2020 - 04:43

@Snkocaman !pip install ycimpute==0.1.1 bu şekilde sorunsuz indirebilirsiniz.

 

picture-279517-1585472947.jpg
m.ali.kula
08.05.2020 - 11:48

Merhaba Elif,

Terminal üzerinden

pip3 install https://download.pytorch.org/whl/cpu/torch-1.1.0-cp37-cp37m-win_amd64.whl
pip3 install https://download.pytorch.org/whl/cpu/torchvision-0.3.0-cp37-cp37m-win_amd64.whl

bu kod satırlarını yaz. Ardından Jupyterde

!pip install ycimpute 

 çalıştır .En son  

from ycimpute.imputer import knnimput

ile çağırabilirsin. İyi çalışmalar.

Snkocaman
27.06.2020 - 02:50
merhaba terminal üzerinden derken tam olarak nereye yazacağız? pip3 install https://download.pytorch.org/whl/cpu/torch-1.1.0-cp37-cp37m-win_amd64.whl
Arife Elif Şen
08.05.2020 - 10:19
Evet bu şekilde çalıştı, teşekkür ederim.