Turkcell | Geleceği Yazanlar

Soru & Cevap

Android eclipse appcompat v7 hatası

12.04.2014 - 19:31

Merhabalar, eclipse sdk'yı son güncellememden sonra yeni proje actıgımda appcompat v7 diye bir kutuphane ekliyor. Biraz arastırdım bu konuyu iyi bir kütüphane olduğunu düsünenler var fakat benim için su an oyle olmadı. 

Yeni proje actığımda kendiliğinden hata veriyor. Projenin uzerinde kırmızı bir unlem isareti oluyor. Neden hata alıyorum bulamadım.Ve yeni bir fragment layout olusturuyor. Artık baslangıcta iki tane layout olusmaya basladı. Fragment layout'u sildiğimde daha fazla hata alıyorum.

Ne yapmam lazım fragment layout'u kullanmak istemiyorum. Cevaplarınızı bekliyorum

 

17375 Görüntülenme

11 Cevap

Mustafa
17.12.2014 - 11:41

Takip ettigim bir blogta detaylıca anlatmış bi göz at istersen http://khblog.net/makale/76/android-eclipsesdk-appcompat-v7-hatasi-ve-cozumu.html

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Hakan Atak
03.12.2014 - 01:16

Soruyu soralı baya olmuş. Yeni bir sorunun zamanıdır :) son android sdk güncellemesini yapan var mı? (Android SDK tools 23.0.5) Bu güncellemeden sonrada appcompat ile ilgili bir takım problemlerle karşılaştım . Sorunları aşabilirsem cevabı burda paylaşıcam. Son güncellemeyi yapan arkadaşlar varsa yardımlarınızı bekliyorum.

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Mehmet Akif AKTAŞ
01.12.2014 - 23:00

Eclipse'yi yeniden kururak da çözebilirsin.

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Murat ÇETİN
01.12.2014 - 20:04

http://agurel.com/index.php/android/eclipsede-appcompat-v7-olmadan-android-projesi-olusturmak#more-54

 

bence net açıklamış çalıştı

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

levent inan
09.07.2014 - 20:13

Net Çözüm >

http://www.r10.net/android-amp-ios-uygulama-gelistirme/1289707-appcompat-v7-hatasi-hakkinda-sorun-yasan-arkadaslar-icin-cozum.html

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Fikri Karadereli
06.05.2014 - 15:14

Selam,

Yeni proje açarken appcompat v7 ve fragment layout oluşmasını istemiyorsanız şu adımları uygulayabilirsiniz;

File -> New -> Android Application Project diyip gerekli alanları doldurup Next diyoruz. İkinci pencerede Create activity ikonunu kaldırıp  Finish e tıklıyoruz.

Proje oluştuktan sonra projeyi sağ tıklayıp New -> Other diyoruz (Ctrl + N kısayolunu da kullanabilirsiniz). Android in altından Android Activity i seçiyoruz. Next dedikten sonra Empty Activity i seçerek tekrar Next diyoruz. Gelen ekranda Launcher Activity i işaretleyip Finish diyoruz. 

Hepinize kolay gelsin.

 

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Kader Çelik
18.06.2014 - 16:24
Merhaba bende bunları deniyorum ama bende Empty Activity i seçeneği yok blank,fullscreen,login,master/detail flow ve setting activity seçenekleri var.Lütfen yardım edin
Sultan
21.10.2014 - 15:14
bu cozum işime yaradi.. tesekkurler..
Fikri Karadereli
10.01.2015 - 04:05
Rica ederim.
Samir Samadov
06.08.2015 - 11:44
bilgilendirme için teşekkürler adımları takip edilice No Launcher activity found! hatası ile karşılaştım araştırma yaptım ve aşağında AndroidMaifest dosyaında tanımlalamrı yapınca çözüldü, faydası olması dileği ile <application android:label="@string/app_name" android:icon="@drawable/icon"> <activity android:name="ExampleActivity" android:label="@string/app_name"> <intent-filter> <action android:name="android.intent.action.MAIN" /> // YENİ EKLENEN 1 <category android:name="android.intent.category.LAUNCHER" /> // YENİ EKLENEN 2 </intent-filter> </activity> </application>
İsmail
25.04.2014 - 10:46

Eğer fragmenti kullanmak istemiyorsan layout dosyasını silebilir kod içerisinden de fragment ile alakalı bölümü ve if koşulunu kaldırırsan eski haline gelecektir yapı. 

Son sürümde neden fragment kullanmaya yönlendirmiş google anlamadım ama vardır bi bildiği diye düşünüyorum.

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

samet
25.04.2014 - 17:36
hocam olmadı malefes yada ben yapamadım https://www.facebook.com/samet.karol lütfen benimle iletişime geçebilrmisiniz
İsmail
21.10.2014 - 16:13
Şuan mesaideyim akşam 8 den sonra sana ulaşacağım samet.
Hakan Atak
14.04.2014 - 18:37

Cevaplarınız için teşekkurler şimdilik bu hatayı astım gibi gorunuyor. Windows kullanıcısıyım son guncellemeyle geliyormus anladıgım kadarıyla bu kutuphane herkes farklı bir cozum yolu soylemis tam bir düzeltme yolu yok sanırım neyse ki cozdum bir sekilde.

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

İbrahim Gündüz
13.04.2014 - 12:39

Bilgisayarınız 64 bit ise kütüphaneler ile alakalı bir sorun olduğunu düşünüyorum. Beni 1 hafta önceki bilgisayarım 32 bit iken 64 bit e geçiş yaptığımda bu sorun ile karşılaştım. Linux/Ubuntu kullanıcısıyım. Kolsolda bazı kütüphaneleri yükleyerek sorunu çözdüm. Sizin işletim sisteminiz linux ise, eclipse'de consola düşen hata mesajını google da aratmanız ve stakoverflow da karşınıza çıkan çözümleri denemenizi öneririm. Ben o şekilde hallettim. Ancak windows kullanıcısı iseniz, sorunu nasıl halledersiniz bilemiyorum :(

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Alican Akkuş
13.04.2014 - 02:12

Bu hata ile karşılaşan çok arkadaşım oldu . Yeni sdk sürümünden kaynaklı bir sorun gibi gözüküyor . Uygulamayı Android 4.4 oncesi bir sürümle compile ederseniz sorun çözülür sanırım .

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

ömer
12.04.2014 - 23:21

mehraba hakan. malesef yeni güncellemede aynısı bendede oldu ben yaptığım projedede seninkiyle aynı hatayı veriyordu projeyi silip yeniden yapınca o sorun ortadan kalktı.Bide appcompat_v7 altındaki uygulamada hata varsa src de vardır. Bu hatayı ctrl+shift+o yapınca ortadan kaldırabilirsin.

Sitede yorum yapabilmek için giriş yapın ya da üye olun.

Sitedeki sorulara cevap verebilmek için giriş yapın ya da üye olun.